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IntroductionIntroduction

In this guide, you’ll find a compilation of BNet.Builder tips from BNet.News, In this guide, you ll find a compilation of BNet.Builder tips from BNet.News, 

the Bayesian Belief Newsletter published by Charles River Analytics, Inc.

For BNet EngineKit™ tips  click hereFor BNet.EngineKit™ tips, click here.
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BNet.Builder User TipBNet.Builder User Tip

Rapid CPT Data Entry 

BNet.Builder offers a number of ways to speed up entering data 
into probability tables. 

One example is entering the same values into multiple rows in a 
CPT. The value for each cell could be entered one at a time, but if 
the table is large, then filling in each cell by hand becomes time 
consuming. One way to speed things up is to group cells that need 
the same values together and set all of the values at once  as the same values together and set all of the values at once, as 
follows:

1. Click and drag column headers for the parent nodes until all rows 
that need to have similar values are together.

2. Highlight the rows which need to have the same values by 
clicking the row headers. Press and hold the control key and click 
on other rows if you need to add more.

3. Set the values all at once using the value sliders or by entering g y g
the numbers in the fields above the value sliders. 

Note: You can also copy and paste values from one row to another, 
or from Excel or other spreadsheets.
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BNet.Builder User TipBNet.Builder User Tip

Easy Network Layout 

Two buttons in BNet.Builder can help you create clean, attractive, organized networks: 

Magnetic grid and Hierarchical layout. 

Magnetic grid: To quickly and easily lines up nodes, click the Magnetic grid button. When 

Magnetic grid is on, nodes snap to the grid when you create or move them.

Hierarchical layout: To adjust the layout of the entire network, click the Hierarchical 

layout button. This feature aligns child nodes beneath their parent nodes. layout button. This feature aligns child nodes beneath their parent nodes. 

You can select Undo from the Edit menu (or use the Control + Z keyboard shortcut) to 

return to the previous layout  
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return to the previous layout. 



BNet.Builder User TipBNet.Builder User Tip

Belief Update Settings

BNet.Builder features advanced belief updating technology, which 
means you never have to "compile" your network or switch back-and-ea s you e e a e to co p e you et o o s tc bac a d
forth between edit and query modes. Beliefs are updated 
automatically after any modification you make to your network. 

In some cases (for example when working with large networks) you 
may not want beliefs to be updated automatically for performance 
reasons. BNet.Builder gives you total control over when belief 
updating occurs. 

To select belief update settings:
1. Open the Network Properties by:

S l ti  th  Wi d N t k P ti   itSelecting the Window->Network Properties menu item
Right-clicking in the main network view and selecting Network 
Properties
Using the Ctrl+5 keyboard shortcut

2  Select the Belief Update tab2. Select the Belief Update tab
3. Place a checkmark next to the modifications after which you'd like 

beliefs to be automatically updated.
Beliefs will only be updated automatically after the modifications 
that are checked. To manually update beliefs, either click the 
Update beliefs toolbar button or select the Tools->Update beliefs 
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Update beliefs toolbar button or select the Tools->Update beliefs 
menu item. 



BNet.Builder User TipBNet.Builder User Tip

Mutual Information 

BNet.Builder provides easy access to a form of sensitivity 
analysis called mutual information. The mutual information 
for a node (called the query node) in a Bayesian network is 
a value for every other node in the Bayesian network that 
represents how new evidence for the node would increase 
certainty in the beliefs of the query node. Using mutual 
information, you can determine the node you should 
b i  id  f   i  i  h   i  h  obtain evidence for to increase certainty the most in the 

beliefs of the query node. The higher the mutual 
information value, the more that the evidence for that 
node will increase certainty in the beliefs of the query 
node. 

To display mutual information, first open the Mutual 
Information window using one of the following procedures:

- Right-click on a node and select Mutual Information
Use the Ctrl+2 shortcut- Use the Ctrl+2 shortcut

- Select Mutual Information from the Window menu

When the Mutual Information window is open, you can 
select any node in the network to view its mutual 
information values  
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BNet.Builder User TipBNet.Builder User Tip

Working with States

BNet.Builder makes it easy to work with the states of a node. Both 
the expanded node and the Node Properties window contain tools for 
adding, renaming, reordering, and removing states.

To add a new state to a node simply click the "Add a new state" 
button, which looks like a plus sign. A new state will then be added to 
the node.

To rename a state click on the state name to begin editing it. When
you're finished, either press the Enter key or click a different area of 
the screen to rename the state.

T  d   t t  d  th  i  i  (j t t  th  l ft f th  t tTo reorder a state, drag the grip icon (just to the left of the state
name) up or down. As you drag, you'll see a horizontal line where the
state will be placed. Drop the state in the new position to reorder it.

To remove a state, first select it by clicking it, and then click the
"Remove the selected state button" which looks like the letter X  Note"Remove the selected state button" which looks like the letter X. Note
that you cannot remove a state from a node that has only two states,
because every node must have at least two states. 
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BNet.Builder User TipBNet.Builder User Tip

Node Description

The Node Properties window in BNet.Builder allows you to provide a 
textual description for a node. The node description can include an 
unlimited length of text for you to provide information to describe unlimited length of text for you to provide information to describe 
your node.

To view or edit a node's description:

1  Open the Node Properties window  You can do this in one of 1. Open the Node Properties window. You can do this in one of 
three ways:

Select the Node Properties item from the Window menu.
Right-click a node and select the Node Properties item.
Use the Ctrl+3 keyboard shortcut.

2. When the Node Properties window opens, click the Description 
tab at the bottom of the window. 

3. Type the text in the white box in the Description tab. 

The node description will be saved to the file so you'll be able to 
reuse it at another time.
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BNet.Builder User TipBNet.Builder User Tip

Grid and Declutter

The magnetic grid can be used to help you position nodes in your Bayesian networks. 

Wh  bl d  'll   f i t id f d t  i  th  b k d d th  l ft  When enabled, you'll see a faint grid of dots in the background and the upper-left corner 

of each node will snap to a dot when being repositioning. To enable the magnetic grid, 

either select the Magnetic Grid toolbar toggle button (a grid of dots with an arrow) or 

select the Vie /Magnetic g id men  itemselect the View/Magnetic grid menu item.

Another tool to assist you in positioning the nodes in your Bayesian networks is the 

Declutter Layout  You may often end up with nodes that overlap each other  especially Declutter Layout. You may often end up with nodes that overlap each other, especially 

when you expand beliefs or evidence on a node. The Declutter Layout slightly repositions 

overlapping nodes so they no longer overlap. 

To switch to the Declutter Layout, click the Declutter toolbar button. 
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BNet.Builder User TipBNet.Builder User Tip

Multiple Networks

When you open multiple Bayesian network files, each network is placed in its own tab in 

the main part of the application window. By default you can only view a single network at 

a time. However, if you drag one of the tabs to the right or bottom side of the window, 

you can view multiple networks at the same time. You can also right-click on a tab for 

more options. 
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BNet.Builder User TipBNet.Builder User Tip

Network Name and Description

The Network Properties window in BNet.Builder allows you to 
provide a textual name and description for a Bayesian network. The 
network name is usually a short string that briefly describes the network name is usually a short string that briefly describes the 
network or is meaningful in some way. The network description can 
include an unlimited length of text for you to provide information to 
describe your network.

To view or edit a network's name and description:To view or edit a network s name and description:

1. Open the Network Properties window. You can do this in one of 
three ways:

- Select the Network Properties item from the Window menu.
- Right-click in the background and select the Network - Right-click in the background and select the Network 
Properties item.

- Use the Ctrl+5 keyboard shortcut.
2. When the Network Properties window opens, click the General 
tab at the bottom of the window
3  Type  the text into the Name or Description text areas3. Type  the text into the Name or Description text areas.

The network name and description will be saved to the file so you'll 
be able to reuse it at another time. 
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BNet.Builder User TipBNet.Builder User Tip

Export to .png Image File

In the BNet.Builder 1.3 release you can save your Bayesian network to an image file, 
which can then be used in publications, documents, and web pages. 

To save your Bayesian network to an image file:

* From the Tools menu, select "Export to PNG..."
* Select the option to save as a .png file. 

Not only can you export the Bayesian network to a .png file, you can also export the 
Conditional Probability Table, Belief and Evidence Summary, and Mutual Information 
views to a .png file as well. 

To export the Conditional Probability Table  Belief and Evidence Summary  or Mutual To export the Conditional Probability Table, Belief and Evidence Summary, or Mutual 
Information views:

* Open the view
* Click on the title bar to select it
* From the Tools menu  select "Export to PNG "  From the Tools menu, select Export to PNG...  
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BNet.Builder User TipBNet.Builder User Tip

Expand/Collapse Beliefs and Evidence

Each node displayed in BNet.Builder has buttons to expand or collapse both beliefs and 

evidence. However, if you want to expand or collapse the beliefs or evidence on many 

nodes at once, clicking the button on each node can become very tedious. BNet.Builder 

1.3 solved this problem by introducing four new commands that expand or collapse the 

beliefs or evidence on all selected nodes.

To use these new commands, select multiple nodes and choose Show beliefs, Show 

evidence, Hide beliefs, or Hide Evidence in the View menu. Each of these commands also 

has a toolbar button (look for the same icons used in the View menu). 
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BNet.Builder User TipBNet.Builder User Tip

Documentation

BNet.Builder includes three useful documents to help you. You can access them in the 

Help menu.

Quick Start Guide - covers the basics of editing & using Bayesian networks.

User's Guide - explains in detail of all of BNet Builder's featuresUser s Guide - explains in detail of all of BNet.Builder s features.

Overview of Bayesian Belief Networks - provides a background on the theory & math 

of Bayesian networks.
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BNet.Builder User TipBNet.Builder User Tip

Inference Engine

BNet.Builder 1.4 introduced an easy way for you to switch between 

several inference engines. Open the Network Properties window and 

select the Engine tab. The selected inference engine will be used in 

all open Bayesian networks.

The Bytecode generator engine is the preferred inference engine for The Bytecode generator engine is the preferred inference engine for 

everyday use. It updates beliefs the fastest, but can run into 

memory problems on large BNs. If you do run into memory 

problems with large BNs, try the Junction tree engine -- it is good 

for very large networks, but can be slower at updating beliefs. 
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BNet.Builder User TipBNet.Builder User Tip

Undo/Redo

Undo and redo are common operations supported by modern applications that let you 

easily restore the application to a previous state when you have unwanted changes. 

BNet.Builder supports undo and redo for all actions that modify the Bayesian network, 

allowing you to undo any change you made to your model. You can find undo and redo in 

the Edit menu and on the main application toolbar. 
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BNet.Builder User TipBNet.Builder User Tip

Fix Original Image: Evidence

BNet.Builder provides easy ways to work with evidence directly on 

th  d  i  th  t k  O   d th  id   the nodes in the network. Once you expand the evidence user 

interface on a node (by clicking the "Show evidence" button), you 

can click the Hard Evidence button for a particular state. This sets 

its e idence to 100% and sets e idence fo  all othe  states to 0%  its evidence to 100% and sets evidence for all other states to 0%. 

You can also drag the Soft Evidence sliders to represent uncertainty 

in the evidence, as well as type numerical evidence into the text 

fieldsfields.

To remove evidence from a node, click its Retract Evidence button, 

found in the bottom-right corner of the node  To remove all found in the bottom-right corner of the node. To remove all 

evidence from a network, click the Retract All Evidence button on 

the toolbar. 
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BNet.Builder User TipBNet.Builder User Tip

Cut / Copy / Paste

BNet.Builder supports cut, copy, and paste operations on an individual node and a group 
of nodes. Simply select the node(s) you want to cut or copy, click the Cut or Copy toolbar 
buttons (or use the Ctrl+X or Ctrl+C keyboard shortcuts)  and then click the Paste toolbar buttons (or use the Ctrl+X or Ctrl+C keyboard shortcuts), and then click the Paste toolbar 
button to paste (or use the Ctrl+V keyboard shortcut).

If you cut or copy a single node, pasting will create a copy of that node and its CPT, as 
well as any edges directed into it. If you cut or copy a group of nodes, pasting will create 
copies of all those nodes and their CPTs  as well as any edges between them  copies of all those nodes and their CPTs, as well as any edges between them. 
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BNet.Builder User TipBNet.Builder User Tip

Upgrading to the Commercial Version

The Evaluation version of BNet.Builder limits networks to five nodes each and displays a 
Charler River Analytics logo in the background. The Commercial version removes the five 
node limit and does not display the logo  node limit and does not display the logo. 

You can purchase a license for BNet.Builder directly on our Web site at 
http://www.cra.com/bnet.builder. All you need to provide is your Activation Key, which 
can be found by going to Help > About BNet.Builder.

Once you purchase a license, we will send you a license file called BNet.key. Then follow 
these steps:

- Click the Upgrade button in the About dialog box
- Select "I have a valid license file" and click Next- Select I have a valid license file  and click Next
- Specify the location of the BNet.key license file and click Finish

The five node limit and the Charles River Analytics logo will then be removed. 
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BNet.BuilderBNet.Builder User TipUser Tip

Network Zoom

Four buttons in BNet.Builder can help you manage network of varying sizes: Zoom In, 
Zoom Out, Fit to Window, and Actual Size. 

Zoom In: To zoom in to a network, click the Zoom In button.  

Zoom Out: To zoom out from a network, click the Zoom Out button.  This feature allows 
you to see more of a network in the network view at once   Note that nodes may only be you to see more of a network in the network view at once.  Note that nodes may only be 
interacted with when at actual size.

Fit to Window: To set the zoom level such that all nodes in the network will fit into the 
current network view screen, click the Fit to Window button.,

Actual Size: To set the zoom level back to the actual size, click the Actual Size button.
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BNet.BuilderBNet.Builder User TipUser Tip

Randomized CPT Entry

Randomized values for all CPTs can be automatically generated by going to the Tools menu 

and choosing the “Randomize all CPTs” option.
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BNet.BuilderBNet.Builder User TipUser Tip

Print

Your Bayesian network can be printed, either be selecting Print from the File Menu, using its 

keyboard shortcut (Ctrl + P), or pressing the toolbar button    ..

Page 22



BNet.BuilderBNet.Builder User TipUser Tip

Normalized Data

If any node in your belief network contains non-normalized data, the BNet.Builder status 

bar displays an error message and a "Normalize" button. Click the button to normalize all 

the data in the belief network.
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BNet.BuilderBNet.Builder User TipUser Tip

Renaming Nodes

If your belief network is showing expanded nodes, click the name of the node to edit it. 

Press Enter or click outside the node and it will automatically expand to display the new 

name. 

You can also rename a node in the Belief and Evidence Summary window or in the 

Conditional Probability Table. 

Page 24



BNet.BuilderBNet.Builder User TipUser Tip

Changing Update Settings for Slower Machines 

If you build a very large belief network with many nodes and/or many states, or if you are 

working on a slower machine, it is recommend that you change the update settings for the 

belief network so BNet.Builder will not automatically update the entire belief network after 

each change. To change the settings for events that trigger an update, click the Belief 

Update tab in the Network Properties window.
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BNet.BuilderBNet.Builder User TipUser Tip

Working with Multiple Networks

When you open multiple Bayesian network files, each network is placed in its own tab in the 

main part of the application window. By default, you can only view a single network at a 

time. However, if you drag one of the tabs to the right or bottom side of the window, you 

can view multiple networks at the same time. You can also right-click on a tab for more 

options.
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BNet.NewsBNet.News

BNet.News is a free newsletter to keep you up to date on BNet software and 
applications of belief networks  It is published approximately every other applications of belief networks. It is published approximately every other 
month.

BNet.News brings you:
Tips and examples you can use in applying belief networks and BNet 
software 
Interesting applications of belief networks 
Upcoming BNet tutorials 
Product announcements Product announcements 
Price and Sale announcements 
Beta test opportunities 

To subscribe or view past issues of BNet.News, visit www.cra.com/bnet.news.To subscribe or view past issues of BNet.News, visit www.cra.com/bnet.news.
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More InformationMore Information

To learn more about our BNet products, visit 

/b twww.cra.com/bnet

Or contact bnet@cra.com. 
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